Back to Mirrakoi.com

Xirus crashes Rhino


(JayR) #1

When I do a xirus loft between a xirus circle and a xirus ellipse and then I pick a wrong point at the “select direction to match” - command rhino crashes.
An other fault is when I try to find an osnap point on an xirus object it doesnt work. Either it dont snap at any quad points but it snaped at every end and midpoint of the control points from the xirus circle


(Pablo Garcia Amorena) #2

Hi @JayR

Can you specify the precise steps that lead you to the crash, such that we can reproduce it? What do you mean by ‘wrong point’?

Yes, point snap is still not there but it will certainly be in next WIP update.

Thank you for reporting,
Pablo


(JayR) #3

Hi Pablo,
because I wasnt shure which point to click in the “select direction to match”- command I picked a previously created Rhino point-object. Then Rhino crashes immidiatly.
An other thing I mentioned: when I select or extract Xirus edge I only can select an edge from one point to an other. Not the whole object edge.
So, when I first create the upper and then the lower half of the edge, then join them to get the complete edge the object turns into a non-Xirus object.
regards Jay


(Pablo Garcia Amorena) #4

Hi @JayR,

I see. This happens because, when prompted ‘select direction to match’, you should choose only one of the 2 displayed options. Anything else will not be recognized by Xirus. This will be fixed in the upcoming update.

Meanwhile, why would you choose a previously created Rhino point object? The ‘direction to match’ points are merely illustrative to choose a matching direction.

Have you tried Parameter Lines select and extract commands?

Pablo


(Nikola) #5

Hi,
I’m in the same boat…rhino crashes every time I try to start license or any of Xirus commands.Some help,suggestions?


(Zsuzsanna Püspöki) #6

Hello @Nikola,

Could you give us further information on the crash? E.g., which OS are you using exactly, is it a Rhino crash or the Rhino window is “not responding”? Feel free to reply to support@mirrakoi.com.

Cheers,
Zsuzsanna